Base de Conhecimento

Como configurar o DDNS em Equipamentos Mikrotik ?

Data de criação: 12/09/2018

Última alteração: 12/09/2018

Para configurar o DDNS no Mikrotik, utilize o script abaixo preenchendo os campos solicitados:

#Versão 3.0e
# IDENTIFICAÇÃO DDNS
:local ddnsuser "meuddns.ddns.com.br"
:local ddnspass "minhasenhaddns"
:local uri "/nic/update\?hostname=$ddnsuser"


:global MeuIPAtual

/tool fetch mode=http address=members.ddns.com.br user=$ddnsuser password=$ddnspass src-path="$uri" dst-path="/ddns.checkip.txt"
:delay 1

#CRIA O ARQUIVO DE LOGS
:local result [/file get ddns.checkip.txt contents]

#MOSTRA NOS LOGS
:log info ("Winco DDNS: ddnsuser = $ddnsuser")
:log info ("Winco DDNS: currentIP = " .$result)
:log info ("Winco DDNS: Realizado Atualização do DDNS")
:set MeuIPAtual $result

Top